Jump to content
IPSViet.com

Bim

(BIM43) Chatbox 3.1.3

Bim

Please don't suggest me to add new features. I made it because I love a simple application.

Message added by Bim

Recommended Posts

Just now, tew said:

@Bim @admin

Hi, I have a chat problem. I have version 1.3.4, I want to go for a new version, which is 2.0, but I can not. After updating to 2.0 chat does not load at all, no posts appear. Only the wheel is spinning. I deleted the cache, removed version 1.3.4 and installed new (2.0) and nothing. What could be wrong?

Try to uninstall and reinstall.

Share this post


Link to post
Share on other sites

@Bim have a problem with uninstall:

Error: Using $this when not in object context (0)

system/Application/Application.php(3762): IPS\Member\_ProfileStep::deleteByApplication(Object(IPS\bimchatbox\Application))

Share this post


Link to post
Share on other sites

I installed this app onto our forum running IPB - 4.2.1 today and I can't get it to work.  It seemed to install fine, is listed in my applications, and I can see it when I go to the Manage Block editor on the forums, but no matter where I put it it says "This block cannot be shown.  It may be because it is unable to show on this specific page or it will show after the page is reloaded."  Reloading doesn't show it.  Moving it anywhere - anywhere at all - doesn't show it.  

 

In the ACP I have an Enable and Disable option.  Then in Permissions I have an Application button.  If it is online there are no other options.  If I toggle it off, it gives me an offline permission menu and message box.  I have a downward arrow as my last option and that gives me: View details, upload new version, uninstall.  I've tried uninstalling the app and reinstalling and still can't get it work.  

 

Can you help?

Share this post


Link to post
Share on other sites

Ahhhhh!  Okay, I didn't realize there was a separate set up in another place.  I just found that and got it up and running!  Thank you SOOO much!

Share this post


Link to post
Share on other sites

Okay, well is there a way to stop it from doubling every entry?  I've run the support tool in the ACP and cleared the cache but that didn't help.  It is posted the chat and then 10 seconds later, posting it again.

Quote

Laurie-BethToday 2:54 PM  

cache emptied 

Laurie-BethToday 2:54 PM  

cache emptied 

Laurie-BethToday 2:52 PM  

why is it doubling everything 

Laurie-BethToday 2:52 PM  

why is it doubling everything 

 

Share this post


Link to post
Share on other sites
4 hours ago, lbb said:

Okay, well is there a way to stop it from doubling every entry?  I've run the support tool in the ACP and cleared the cache but that didn't help.  It is posted the chat and then 10 seconds later, posting it again.

 

I can not reproduce this problem. Try to run Get Support in ACP to clear the badly cache and test  it on default theme.

Share this post


Link to post
Share on other sites
15 hours ago, Sipsb said:

Hello @Bim, my client has such a problem, what can be? IPS 4.2.1

598a3d42d19dd_2017-08-091_33_20.png.49f7f836a971a90d9caa4f8674de1b72.png

598a3e0cb21ed_9_2017.1_30_59.thumb.gif.ad76b368d6536473819ffab6bab4aa2e.gif

 

Badly cache, run "Get Support" to clear it.

Share this post


Link to post
Share on other sites
  • If you're using IPS 4.1.x and running Get Support can not solve the problem, upgrading to IPS 4.2.2.
  • If you already editted templates or CSS of Chatbox, you need to revert them to default after upgrading to 2.x.
  • And note that it will not work if turning on Designer Mode or Dev Mode. 

(Don't pm me how to customize the code, how to add new features,... I made it for the end users and I don't support for coding)

Share this post


Link to post
Share on other sites
13 hours ago, Bim said:
  • If you're using IPS 4.1.x and running Get Support can not solve the problem, upgrading to IPS 4.2.2.
  • If you already editted templates or CSS of Chatbox, you need to revert them to default after upgrading to 2.x.
  • And note that it will not work if turning on Designer Mode or Dev Mode. 

(Don't pm me how to customize the code, how to add new features,... I made it for the end users and I don't support for coding)

host free tớ cũng bị xoay xoay như thế bim ạ =.='' .. chạy get support rồồi mà ko đc, lại là mới cài nữa chứ :( .. 

Hidden Content

    Give reaction to this post to see the hidden content.
Demo nheé bim... ko biết là do host hay do gì nữa ~"~...

  • Like 2

Share this post


Link to post
Share on other sites
Just now, nobita said:

host free tớ cũng bị xoay xoay như thế bim ạ =.='' .. chạy get support rồồi mà ko đc, lại là mới cài nữa chứ :( ..  

tình trạng này thường là do host hoặc phên bản ips nên mình cũng ko xác định dc lỗi. Hôm qua cũng có 1 bạn bị vậy, lỗi là tất cả các  ajax request đều bị gãy với mã lỗi 301 và bị 2 lần requests. Tình trạng này xảy ra với tất cả các ajax request của toàn site ko riêng gì chatbox. Ví dụ bình thường cách 15s là ips nó chạy 1 request để lấy notifications, còn site đó bị lỗi nó chạy 2 cái request mỗi 15s, cái thứ nhất lỗi 301, cái thứ 2 sai url. Ngoài ra còn có bạn thì hosting chặn gì đó ko chạy dc script chat. Mấy vấn đề này mình cũng bó tay.

  • Like 1

Share this post


Link to post
Share on other sites
On 15.08.2017 at 9:09 PM, Bim said:

If you already editted templates or CSS of Chatbox, you need to revert them to default after upgrading to 2.x.

Hello! So I can not edit my chat style?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×