Jump to content
IPSViet.com

Bim

(BIM43) Chatbox 3.0.2

Bim

Please don't suggest me to add new features. I made it because I love a simple application.

Message added by Bim

Recommended Posts

15 hours ago, sciphacker said:

emoji true how to fix it ?

I also have this problem. When I select the emoji, it'll show up as 'true' in the editor/message area instead of the emoji's name.

Share this post


Link to post
Share on other sites
On 3/7/2015 at 4:44 PM, Bim said:

 

chatbox01.png

This is very simple chat system with the basic features:

  • Ajax chat, auto update.
  • Display as IPS widgets, so you can place it in sidebar or top page.
  • Sound notification. User can toggle on/off.
  • Admins/Moderators can block users.
  • Users can ignore some chatters they don't want to see.
  • Load more messages when scrolling end (or top).
  • Announcement (on Top or Tab).
  • Supports emoticons, URL, Image URL (gif, png, jpg)
  • *NEW* Supports 

    Hidden Content

    • Give reaction to this post to see the hidden content.
     to turn any text message into funny GIF and Sticker by using /guggy command (Eg: /guggy I love you
  • *NEW* Supports 

    Hidden Content

    • Give reaction to this post to see the hidden content.
     to finds GIFs and Stickers by using /giphy command (Eg: /giphy happy new year)
  • *NEW* Supports Youtube, playing video in iframe and popup 
  • @mention by clicking on usernames.
  • Flood control.
  • Bad word filters.
  • Time format.
  • Display newer messages in top or bottom.
  • Permissions for viewing, chatting & management.
  • Edit/Delete messages.

Demohttps://demo.ipsviet.com/chatbox/

DOWNLOAD

 

Hidden Content

  • Give reaction to this post to see the hidden content.

 

 

Hidden Content

  • Give reaction to this post to see the hidden content.

 

 

Hidden Content

  • Give reaction to this post to see the hidden content.

  (Supports IPS 4.3.x only)

 

 

 

The chatbox no connect help plis

Share this post


Link to post
Share on other sites
On 5/1/2018 at 1:50 AM, sciphacker said:

emoji true how to fix it ?

Everytime an user use an emoticon (all of them), the sidechat just replace the emoticon with  "true".

Can you fix this issue?

Share this post


Link to post
Share on other sites
On 4/20/2018 at 7:50 AM, PCGamer1981 said:

@Bim A bit of a triple post from me, sorry. :D

There are also issues using Chatbox 3.0.1 from browsers on iOS and IE11 on Windows.

I checked console on IE11 and it's complaining of a JS issue:

error.thumb.png.879e728e95265a9d4f0cb3c8ea4f2b22.png

Also, skin tone changes appear oddly:

error2.png.5c12532455dc30cd55a0506cb24e818e.png

 

On 4/26/2018 at 3:21 PM, culturalhealingandlife@gmail.c said:

members with ipad are not able to use chat and is black screen as others have illustrated above.  Latest updates all around.

 

I believe I was able to fix this for my own site. (Granted I probably broke disconnecting.)  Here is a version with my fix until @Bim get's an actual release out.

 

@Bim internet explorer, iphones/ipads, and probably any browser that's not chrome does not like the assignment in the function parameter

Hidden Content

    Give reaction to this post to see the hidden content.

Removing _0x2d08x11= _0xe164[2] allows the shoutbox to load/function. I'm guessing that's to be used for default value? You might have to do that logic on your own inside the function itself.

 

Any chance you'd be willing to unobfuscate/open source this project? Doing so would give us a lot more room to help debug and expand for our own communities.

 

-JC

Hidden Content

    Give reaction to this post to see the hidden content.

  • Like 3
  • Thanks 2
  • Haha 1

Share this post


Link to post
Share on other sites
On ‎5‎/‎2‎/‎2018 at 10:58 PM, jcsnider said:

 

 

I believe I was able to fix this for my own site. (Granted I probably broke disconnecting.)  Here is a version with my fix until @Bim get's an actual release out.

 

@Bim internet explorer, iphones/ipads, and probably any browser that's not chrome does not like the assignment in the function parameter

Hidden Content

    Give reaction to this post to see the hidden content.

Removing _0x2d08x11= _0xe164[2] allows the shoutbox to load/function. I'm guessing that's to be used for default value? You might have to do that logic on your own inside the function itself.

 

Any chance you'd be willing to unobfuscate/open source this project? Doing so would give us a lot more room to help debug and expand for our own communities.

 

-JC

Hidden Content

    Give reaction to this post to see the hidden content.

thanks for the updated file, i tried this however still having issues for users using IE11, is there anything else i needed to do than overwrite all the files?

 

thanks again

Share this post


Link to post
Share on other sites

Instead of just replacing files you need to install it in Admin Panel -> Applications. Otherwise you will have to hunt down and delete cached javascript files. 

In IE be sure to refresh the page a few times just in case the javascript is cached there as well. 

Share this post


Link to post
Share on other sites

so sorry my bad :) all working thanks for the updated info, hopefully @Bim will get a update out to rectify the Emojis issue :) 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×