Jump to content
IPSViet.com
Sign in to follow this  
doremon

Làm gì khi không import được language?

Recommended Posts

Vấn đề này rất thường xảy ra, nguyên nhân là do hosting hạn chế, thường timeout quá ngắn. Mình đã gặp rất nhiều trường hợp các bạn ko import được file ngôn ngữ cho IPB. Có nhiều cách giải quyết như làm ở localhost xong rồi restore cả db lên host, hoặc chỉ upload file lang lên cache/lang_cache/1/... Như vậy cũng được nhưng nó mất thời gian và bất tiện mỗi khi bạn cài mod mới, hook mới mà bị recache là mất sạch ngay.

Có 1 cách giải quyết vấn đề trên mà với những ai làm quen IPB hay đang dùng IPB cần phải biết đó là Translate Externally... Ưu điểm là không sợ bị lỗi timeout, recache thoải mái ko bị mất ngôn ngữ...

Cách làm:

1. Download file việt hóa này về: (File việt hóa của ipsviet, khá đầy đủ và chính xác)

Hidden Content

    Give reaction to this post to see the hidden content.


2. Tạo thư mục translate ngang hàng với index.php trên diễn đàn, CHMOD nó thành 777

3. Log và ACP -> Look & Feel -> Manage Language -> Dòm bên tay phải của English (USA) bấm nút mũi tên xuống rồi chọn Copy language Pack. Xong đợi 1 chút nó sẽ copy ra 1 gói ngôn ngữ của cái English đó cho bạn. Bây giờ bấm biểu tượng hình cây viết bên tay phải để edit nó, sửa nó thành Việt Nam để dễ nhận dạng, locale là vi, còn lại giữ y ko đụng đến.

4. Cái ngôn ngữ vừa copy ra là bản sao của ngôn ngữ tiếng anh mặc định của IPB, bây giờ việc cần làm là translate nó thành tiếng việt. Bấm mũi tên xuống bên tay phải, chọn Translate Externally... Bây giờ bạn sẽ thấy 1 loạt danh sách các file ngôn ngữ (nó vẫn là tiếng anh không đó)

5. Tiếp theo unzip và upload toàn bộ file đã việt hóa trong file .zip vừa tải ở trên vào thư mục Translate đãtạo ở bước 2. Rồi trở lại giao diện translate. Vì host bị giới hạn timeout nên chúng ta ko thế nào import 1 lần hết tất cả, cứ lần lượt chọn một lần 6-7 file gì đó rồi kéo tuốt xuống dưới bấm cái nút màu đen có chữ Import Selected file. Cứ thế làm cho hết file.

6. Ở giao diện manage language, bên phải ngôn ngữ Việt Nam, bấm nút Recache all... (nằm ở giữa).

Lưu ý nếu ai bị lỗi ở phần viết bài (ko thấy editor hoặc nút quote ko hoạt động) thì ở giao diện manage language, bên tay phải bấm mũi tên xuống, chọn Rebuilt from XML... sau đó đợi một chút nó rebuilt xong thì recache như ở bước 6 lại để sửa lỗi.


Xong, bạn đã có ngôn ngữ tiếng việt cho diễn đàn. Bây giờ hãy xóa thư mục translate đi
 

 

  • Like 10
  • Thanks 1

Share this post


Link to post
Share on other sites

Tớ không thấy Translate Externally... như cậu nói? Khi bấm mũi tên chỉ có:

  • Hidden Content

      Give reaction to this post to see the hidden content.
  • Hidden Content

      Give reaction to this post to see the hidden content.
  • Hidden Content

      Give reaction to this post to see the hidden content.
  • Hidden Content

      Give reaction to this post to see the hidden content.
  • Hidden Content

      Give reaction to this post to see the hidden content.
  • Hidden Content

      Give reaction to this post to see the hidden content.
  • Hidden Content

      Give reaction to this post to see the hidden content.
  • Hidden Content

      Give reaction to this post to see the hidden content.

  • Like 2

Share this post


Link to post
Share on other sites

Tớ không thấy Translate Externally... như cậu nói? Khi bấm mũi tên chỉ có:
  • Hidden Content

      Give reaction to this post to see the hidden content.
  • Hidden Content

      Give reaction to this post to see the hidden content.
  • Hidden Content

      Give reaction to this post to see the hidden content.
  • Hidden Content

      Give reaction to this post to see the hidden content.
  • Hidden Content

      Give reaction to this post to see the hidden content.
  • Hidden Content

      Give reaction to this post to see the hidden content.
  • Hidden Content

      Give reaction to this post to see the hidden content.
  • Hidden Content

      Give reaction to this post to see the hidden content.




Tut trên bị thiếu, trước tiên cần mở file conf_global.php thêm vào dòng này phía trước cái ?>

Hidden Content

    Give reaction to this post to see the hidden content.



Nếu có rồi thì sửa 0 thành 1, rồi mới làm các bước trên. Khi làm xong thì xóa dòng đó đi hoặc sửa 1 thành 0 để vào lại diễn đàn.

  • Like 2

Share this post


Link to post
Share on other sites

Vẫn không thấy cái Translate Externally... đâu! Mà đổi thành như cậu ns! Tự nhiên site tớ không vào được! Vào ACP nó hiện ra lỗi sau:

Settings Need Updating
Modules Need Updating
System Modules Need Updating.
-- Last import run: --
-- Last XML export: 07-April 12
Forums Modules Need Updating.
-- Last import run: --
-- Last XML export: 07-April 12
Members Modules Need Updating.
-- Last import run: --
-- Last XML export: 07-April 12
Click Here to reimport all apps to make sure your settings are up-to-date.
Tasks Need Updating
Help Files Need Updating
BBCodes Need Updating
System BBCodes Need Updating.
-- Last import run: --
-- Last XML export: 07-April 12
Click Here to reimport all apps to make sure your settings are up-to-date.

Sửa lại thành define('IN_DEV', ); lại zô ngon và mất lỗi đó!

Share this post


Link to post
Share on other sites

Vẫn không thấy cái Translate Externally... đâu! Mà đổi thành như cậu ns! Tự nhiên site tớ không vào được! Vào ACP nó hiện ra lỗi sau:


Sửa lại thành define('IN_DEV',); lại zô ngon và mất lỗi đó!

Thì bật dev mode lên là ko vào dc site, làm xong hết thì xóa dòng đó đi là ok mà.
Translate Externally ko xuất hiện với language mặc định là English, bởi thế mới cần copy ra.

Share this post


Link to post
Share on other sites

Đó là do host của bạn có vấn đề.

Server error

The website encountered an error while retrieving

Hidden Content

    Give reaction to this post to see the hidden content.
. It may be down for maintenance or configured incorrectly

.

Share this post


Link to post
Share on other sites

Đó là do host của bạn có vấn đề.

Host chập cheng gì à? Cái này có cách fix không? Hay là tạo host mới luôn, đồ free mà! Khi nào biết ít nhiều mới thuê host mà dùng!

Share this post


Link to post
Share on other sites

He he, thank Doremon nhé, đang cần cái này thì Doremon chỉ cho. Chứ làm mấy kiểu kia khổ quá à.
Góp ý chút nhé Doremon:
Thứ nhất: Chỉ việc tạo thư mục translate ngang hàng với index và chmod về 777 rồi vào luôn ACP như các bước bác chỉ trên mà không cần sửa file con_global.php. Vì khi vào phần Manager Language để ý phần trên của các gói ngôn ngữ có tip thông báo cho việc Translate Externally chỉ việc click vào đó là vào bảng dịch thôi :D.

Thứ 2: Sau khi chọn file dịch như bước 5 trước khi ấn vào nút Import Select Files thì file bóp vào nút Select Modifield trước mới được.

Chỉ có thế thôi còn lại làm như bác Doremon chỉ dẫn.

Share this post


Link to post
Share on other sites

He he, thank Doremon nhé, đang cần cái này thì Doremon chỉ cho. Chứ làm mấy kiểu kia khổ quá à.
Góp ý chút nhé Doremon:
Thứ nhất: Chỉ việc tạo thư mục translate ngang hàng với index và chmod về 777 rồi vào luôn ACP như các bước bác chỉ trên mà không cần sửa file con_global.php. Vì khi vào phần Manager Language để ý phần trên của các gói ngôn ngữ có tip thông báo cho việc Translate Externally chỉ việc click vào đó là vào bảng dịch thôi :D.

Thứ 2: Sau khi chọn file dịch như bước 5 trước khi ấn vào nút Import Select Files thì file bóp vào nút Select Modifield trước mới được.

Chỉ có thế thôi còn lại làm như bác Doremon chỉ dẫn.


:) vì có bạn ở trên ko thấy chữ đó , nên mình hướng dẫn luôn vào DEV MODE cho bảo đảm.

Share this post


Link to post
Share on other sites

Tớ là làm được hết nhưng khi ấn Translate Externally... nó báo lỗi"

IP.Board Message
Please create a directory called 'translate' in the root forum directory (the same directory that contains your 'initdata.php' file and 'admin' folder). Please make sure PHP has write permissions into this directory. CHMOD 0777 if in doubt.

Share this post


Link to post
Share on other sites

LỖi rõ ràng thế mà, chưa tạo thư mục translate ngang hàng với initdata.php hoặc chưa chmod 777 kìa

Share this post


Link to post
Share on other sites

LỖi rõ ràng thế mà, chưa tạo thư mục translate ngang hàng với initdata.php hoặc chưa chmod 777 kìa

k tìm thấy initdata.php!~ Còn chmod 777 thì mình biết~

Share this post


Link to post
Share on other sites

OK từ a->Z trừ việc Import Selected file.! Sau khi ấn cái đó nó đòi

Hidden Content

    Give reaction to this post to see the hidden content.
Ấn vào thì nó quay về giao diện ở

Hidden Content

    Give reaction to this post to see the hidden content.
! Xong không thấy cái Translate Externally... đâu cả! Ở bên ngoài

Hidden Content

    Give reaction to this post to see the hidden content.
có ở trên đầu như sau:


External File Translation

A file translation session has been detected. Click

Hidden Content

    Give reaction to this post to see the hidden content.
.
You will not be able to start a new session until you finish the current one.

Ấn vào

Hidden Content

    Give reaction to this post to see the hidden content.
. thì vào khu vực Import Selected file! Ở bên trên đó có:

External File Translation

You can edit the files in the 'translate' directory. Once you have translated the file you can import these changes directly into the database.

Before editing, please set your text editor to save files as UTF-8 regardless of the character set your community uses.

Mới tập tọe nên không biết tí gì

Share this post


Link to post
Share on other sites

Tất nhiên làm xong thì recache mới có hiệu wả. Vì quá trình translate cũ còn nên ko thể tạo mới. Nó đã ghi quá rõ ràng.

Share this post


Link to post
Share on other sites

recache rồi có hiện tượng gì đâu? :| Hay là cậu vs teamviewer rồi tớ xem cậu làm nhé! Được không? Nếu rảnh thì giúp tớ! Thân

Share this post


Link to post
Share on other sites

Mình đã hiểu nguyên do các bạn kolàm được đó là vì khi bấm Translate Externally thì IPB sẽ tự creat lại bản lang tiếng anh vào thư mục Translate. Vì vậy các bạn phải làm ngược lại, tức là bấm Translate Externally xong rùi mới upload đè lên các file lang trong thư mục Translate. Mình đã sửa lại tut cho dễ hiểu.

  • Like 1

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...